Merge "Add bgpcep to rpm packaging."
[integration.git] / packaging / rpm / opendaylight-controller-dependencies.spec
1 Name: opendaylight-controller-dependencies
2 Version: 0.1.0
3 Release: 0.4.0%{?dist}
4 Summary: OpenDaylight SDN Controller Dependencies
5 Group: Applications/Communications
6 License: EPL
7 URL: http://www.opendaylight.org
8
9 # The sources are built by the other projects so just copy them:
10 # cp ~/rpmbuild/BUILD/opendaylight-controller-0.1.0/opendaylight/distribution/opendaylight/target/distribution.opendaylight-osgipackage.zip ~/rpmbuild/SOURCES/opendaylight-controller-%{version}.zip
11 # cp ~/rpmbuild/BUILD/opendaylight-ovsdb-0.1.0/distribution/opendaylight/target/distribution.ovsdb-1.0.0-SNAPSHOT-osgipackage.zip ~/rpmbuild/SOURCES/opendaylight-ovsdb-%{version}.zip
12 Source0: opendaylight-controller-%{version}.zip
13 Source1: opendaylight-ovsdb-%{version}.zip
14 BuildArch: noarch
15 Requires: java >= 1:1.7.0
16
17 # Here you should have at least dependencies for the packages containing .jar
18 # files that you want to create symlinks to:
19 # First pass just use everything from the distribution zip.
20 #Requires: slf4j
21
22 # This is the directory where all dependencies will go:
23 # /usr/share/java/opendaylight-controller-dependencies
24 %global deps_dir %{_javadir}/%{name}
25
26 %description
27 OpenDaylight SDN Controller Dependencies
28
29
30 %prep
31
32 %setup -q -c -n opendaylight-controller-dependencies-%{version}
33 %setup -q -T -a 1 -c -n opendaylight-ovsdb-dependencies-%{version}
34
35
36 %build
37 exit 0
38
39
40 %install
41
42 mv -f ../opendaylight-controller-dependencies-%{version}/opendaylight/lib/* opendaylight/lib/
43 mv -f ../opendaylight-controller-dependencies-%{version}/opendaylight/plugins/* opendaylight/plugins/
44
45 # Create the directory for the dependencies:
46 mkdir -p %{buildroot}%{deps_dir}
47
48 for src in $( ls -I "org.opendaylight.*" opendaylight/lib );
49 do
50     #tgt=$(echo ${src} | sed -e "s/-[0-9].*/.jar/")
51     #mv opendaylight/lib/${src} %{buildroot}%{deps_dir}/${tgt}
52     mv opendaylight/lib/${src} %{buildroot}%{deps_dir}/${src}
53 done
54
55 for src in $( ls -I "org.opendaylight.*" opendaylight/plugins );
56 do
57     #tgt=$(echo ${src} | sed -e "s/-[0-9].*/.jar/")
58     #mv opendaylight/plugins/${src} %{buildroot}%{deps_dir}/${tgt}
59     mv opendaylight/plugins/${src} %{buildroot}%{deps_dir}/${src}
60 done
61
62
63 %files
64
65 # Own the directory containing the dependencies and its contents:
66 %{deps_dir}
67
68
69 %changelog
70 * Sat Jan 18 2014 Sam Hague <shague@redhat.com> - 0.1.0-0.4.0
71 - Minor cleanup to setup option.
72
73 * Thu Jan 02 2014 Sam Hague <shague@redhat.com> - 0.1.0-0.3.0
74 - Updates to include building distributions.
75
76 * Fri Nov 22 2013 Sam Hague <shague@redhat.com> - 0.1.0-0.2.0
77 - Updates to support building rpm with jenkins.
78
79 * Fri Nov 01 2013 Sam Hague <shague@redhat.com> - 0.1.0-0.1.20131007git31c8f18
80 - Initial Fedora package.