Bump versions to 4.0.8-SNAPSHOT
[controller.git] / opendaylight / md-sal / mdsal-it-base / pom.xml
1 <?xml version="1.0" encoding="UTF-8"?>
2 <!-- vi: set et smarttab sw=4 tabstop=4: -->
3 <!--
4 Copyright (c) 2014 Cisco Systems, Inc. and others.  All rights reserved.
5
6 This program and the accompanying materials are made available under the
7 terms of the Eclipse Public License v1.0 which accompanies this distribution,
8 and is available at http://www.eclipse.org/legal/epl-v10.html
9 -->
10 <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
11   <modelVersion>4.0.0</modelVersion>
12   <parent>
13     <groupId>org.opendaylight.odlparent</groupId>
14     <artifactId>bundle-parent</artifactId>
15     <version>9.0.6</version>
16     <relativePath/>
17   </parent>
18
19   <groupId>org.opendaylight.controller</groupId>
20   <artifactId>mdsal-it-base</artifactId>
21   <version>4.0.4-SNAPSHOT</version>
22   <packaging>bundle</packaging>
23
24   <dependencyManagement>
25     <dependencies>
26       <dependency>
27         <groupId>org.opendaylight.mdsal</groupId>
28         <artifactId>mdsal-artifacts</artifactId>
29         <version>8.0.5</version>
30         <type>pom</type>
31         <scope>import</scope>
32       </dependency>
33       <dependency>
34         <groupId>org.opendaylight.controller</groupId>
35         <artifactId>controller-artifacts</artifactId>
36         <version>${project.version}</version>
37         <type>pom</type>
38         <scope>import</scope>
39       </dependency>
40     </dependencies>
41   </dependencyManagement>
42
43   <dependencies>
44     <dependency>
45       <groupId>org.opendaylight.odlparent</groupId>
46       <artifactId>opendaylight-karaf-empty</artifactId>
47       <type>zip</type>
48     </dependency>
49     <dependency>
50       <groupId>org.opendaylight.mdsal</groupId>
51       <artifactId>mdsal-binding-api</artifactId>
52     </dependency>
53         <!-- Dependencies for pax exam karaf container -->
54     <dependency>
55         <groupId>org.ops4j.pax.exam</groupId>
56         <artifactId>pax-exam-container-karaf</artifactId>
57         <scope>compile</scope>
58     </dependency>
59     <dependency>
60         <groupId>org.ops4j.pax.exam</groupId>
61         <artifactId>pax-exam-junit4</artifactId>
62         <scope>compile</scope>
63     </dependency>
64     <dependency>
65         <groupId>org.ops4j.pax.exam</groupId>
66         <artifactId>pax-exam</artifactId>
67         <scope>compile</scope>
68     </dependency>
69     <dependency>
70         <groupId>org.ops4j.pax.tipi</groupId>
71         <artifactId>org.ops4j.pax.tipi.junit</artifactId>
72         <version>4.12.0.1</version>
73         <scope>runtime</scope>
74     </dependency>
75     <dependency>
76         <groupId>org.ops4j.pax.tipi</groupId>
77         <artifactId>org.ops4j.pax.tipi.hamcrest.core</artifactId>
78         <version>1.3.0.1</version>
79         <scope>runtime</scope>
80     </dependency>
81     <dependency>
82         <groupId>org.ops4j.pax.url</groupId>
83         <artifactId>pax-url-aether</artifactId>
84         <scope>compile</scope>
85     </dependency>
86
87     <!-- Referenced by pax-exam-features, needs to be pulled into local repository -->
88     <dependency>
89         <groupId>org.ops4j.base</groupId>
90         <artifactId>ops4j-base-monitors</artifactId>
91         <version>1.5.1</version>
92     </dependency>
93     <dependency>
94         <groupId>org.apache.geronimo.specs</groupId>
95         <artifactId>geronimo-atinject_1.0_spec</artifactId>
96         <!-- FIXME: remove this override once pax-exam is aligned with pax-web -->
97         <version>1.0</version>
98     </dependency>
99
100     <dependency>
101         <groupId>org.apache.karaf.features</groupId>
102         <artifactId>org.apache.karaf.features.core</artifactId>
103         <scope>compile</scope>
104     </dependency>
105     <dependency>
106         <groupId>org.osgi</groupId>
107         <artifactId>osgi.core</artifactId>
108         <scope>compile</scope>
109     </dependency>
110     <dependency>
111         <groupId>junit</groupId>
112         <artifactId>junit</artifactId>
113         <scope>compile</scope>
114     </dependency>
115   </dependencies>
116 </project>