Adding sal-compatibilty feature 74/10274/2
authorEd Warnicke <eaw@cisco.com>
Tue, 26 Aug 2014 18:49:49 +0000 (13:49 -0500)
committerEd Warnicke <eaw@cisco.com>
Wed, 27 Aug 2014 01:13:04 +0000 (20:13 -0500)
Change-Id: Ifbafc7cea387e0ab5248c1d9dae10426913ed2f9
Signed-off-by: Ed Warnicke <eaw@cisco.com>
features/adsal-compatibility/pom.xml [new file with mode: 0644]
features/adsal-compatibility/src/main/resources/features.xml [new file with mode: 0644]
features/pom.xml

diff --git a/features/adsal-compatibility/pom.xml b/features/adsal-compatibility/pom.xml
new file mode 100644 (file)
index 0000000..44b9b09
--- /dev/null
@@ -0,0 +1,208 @@
+<?xml version="1.0" encoding="UTF-8"?>\r
+<!--\r
+ Necessary TODO: Put your copyright here.\r
+\r
+ This program and the accompanying materials are made available under the\r
+ terms of the Eclipse Public License v1.0 which accompanies this distribution,\r
+ and is available at http://www.eclipse.org/legal/epl-v10.html\r
+--><project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">\r
+   <modelVersion>4.0.0</modelVersion>\r
+   <parent>\r
+     <groupId>org.opendaylight.controller</groupId>\r
+     <artifactId>commons.opendaylight</artifactId>\r
+     <version>1.4.2-SNAPSHOT</version>\r
+     <relativePath>../../opendaylight/commons/opendaylight</relativePath>\r
+   </parent>\r
+   <artifactId>features-adsal-compatibility</artifactId>\r
+   <packaging>jar</packaging>\r
+   <properties>\r
+      <features.file>features.xml</features.file>\r
+      <feature.test.version>0.6.2-SNAPSHOT</feature.test.version>\r
+   </properties>\r
+   <dependencies>\r
+    <!--\r
+      Necessary TODO: Put dependencies on any feature repos\r
+      you use in your features.xml file.\r
+\r
+      Note: they will need to be <type>xml</xml>\r
+      and <classifier>features</classifier>.\r
+      One other thing to watch for is to make sure they are\r
+      <scope>compile</compile>, which they should be by default,\r
+      but be cautious lest they be at a different scope in a parent pom.\r
+\r
+      Examples:\r
+        <dependency>\r
+          <groupId>org.opendaylight.yangtools</groupId>\r
+          <artifactId>features-yangtools</artifactId>\r
+          <version>0.6.2-SNAPSHOT</version>\r
+          <classifier>features</classifier>\r
+          <type>xml</type>\r
+        </dependency>\r
+        <dependency>\r
+          <groupId>org.opendaylight.controller</groupId>\r
+          <artifactId>features-mdsal</artifactId>\r
+          <version>1.1-SNAPSHOT</version>\r
+          <classifier>features</classifier>\r
+          <type>xml</type>\r
+        </dependency>\r
+        <dependency>\r
+          <groupId>org.opendaylight.openflowplugin</groupId>\r
+          <artifactId>features-openflowplugin</artifactId>\r
+          <version>0.0.3-SNAPSHOT</version>\r
+          <classifier>features</classifier>\r
+          <type>xml</type>\r
+        </dependency>\r
+    -->\r
+      <dependency>\r
+        <groupId>org.opendaylight.controller</groupId>\r
+        <artifactId>features-mdsal</artifactId>\r
+        <version>${mdsal.version}</version>\r
+        <classifier>features</classifier>\r
+        <type>xml</type>\r
+      </dependency>\r
+      <dependency>\r
+        <groupId>org.opendaylight.controller</groupId>\r
+        <artifactId>features-flow</artifactId>\r
+        <version>${mdsal.version}</version>\r
+        <classifier>features</classifier>\r
+        <type>xml</type>\r
+      </dependency>\r
+      <dependency>\r
+        <groupId>org.opendaylight.controller</groupId>\r
+        <artifactId>features-adsal</artifactId>\r
+        <version>${sal.version}</version>\r
+        <classifier>features</classifier>\r
+        <type>xml</type>\r
+      </dependency>\r
+\r
+    <!--\r
+      Necessary TODO: Put dependencies for bundles directly referenced\r
+      in your features.xml file.  For every <bundle> reference in your\r
+      features.xml file, you need a corresponding dependency here.\r
+\r
+      Examples:\r
+      <dependency>\r
+        <groupId>org.opendaylight.controller</groupId>\r
+        <artifactId>controller-provider</artifactId>\r
+        <version>${project.version}</version>\r
+      </dependency>\r
+      <dependency>\r
+        <groupId>org.opendaylight.controller</groupId>\r
+        <artifactId>controller-model</artifactId>\r
+        <version>${project.version}</version>\r
+      </dependency>\r
+    -->\r
+      <dependency>\r
+        <groupId>org.opendaylight.controller</groupId>\r
+        <artifactId>sal-compatibility</artifactId>\r
+        <version>${mdsal.version}</version>\r
+      </dependency>\r
+\r
+    <!--\r
+      Necessary TODO: Put dependencies for configfiles directly referenced\r
+      in your features.xml file.  For every <configfile> reference in your\r
+      features.xml file, you need a corresponding dependency here.\r
+\r
+      Example (presuming here version is coming from the parent pom):\r
+      <dependency>\r
+        <groupId>org.opendaylight.controller</groupId>\r
+        <artifactId>controller-config</artifactId>\r
+        <version>${project.version}</version>\r
+        <type>xml</type>\r
+        <classifier>config</classifier>\r
+      </dependency>\r
+    -->\r
+\r
+    <!--\r
+      Optional TODO: Remove TODO comments.\r
+    -->\r
+    <!-- test to validate features.xml -->\r
+    <dependency>\r
+      <groupId>org.opendaylight.yangtools</groupId>\r
+      <artifactId>features-test</artifactId>\r
+      <version>${feature.test.version}</version>\r
+      <scope>test</scope>\r
+    </dependency>\r
+    <!-- dependency for opendaylight-karaf-empty for use by testing -->\r
+    <dependency>\r
+      <groupId>org.opendaylight.controller</groupId>\r
+      <artifactId>opendaylight-karaf-empty</artifactId>\r
+      <version>${commons.opendaylight.version}</version>\r
+      <type>zip</type>\r
+    </dependency>\r
+    <!-- Uncomment this if you get an error : java.lang.NoSuchMethodError: org.slf4j.helpers.MessageFormatter.format(Ljava/lang/String;Ljava/lang/Object;Ljava/lang/Object;)Lorg/slf4j/helpers/FormattingTuple;\r
+    <dependency>\r
+      <groupId>org.slf4j</groupId>\r
+      <artifactId>slf4j-simple</artifactId>\r
+      <version>1.7.2</version>\r
+    </dependency>\r
+    -->\r
+\r
+   </dependencies>\r
+   <build>\r
+      <resources>\r
+         <resource>\r
+            <directory>src/main/resources</directory>\r
+            <filtering>true</filtering>\r
+         </resource>\r
+      </resources>\r
+      <plugins>\r
+         <plugin>\r
+            <groupId>org.apache.maven.plugins</groupId>\r
+            <artifactId>maven-resources-plugin</artifactId>\r
+            <executions>\r
+               <execution>\r
+                  <id>filter</id>\r
+                  <phase>generate-resources</phase>\r
+                  <goals>\r
+                     <goal>resources</goal>\r
+                  </goals>\r
+               </execution>\r
+            </executions>\r
+         </plugin>\r
+         <plugin>\r
+            <groupId>org.codehaus.mojo</groupId>\r
+            <artifactId>build-helper-maven-plugin</artifactId>\r
+            <executions>\r
+               <execution>\r
+                  <id>attach-artifacts</id>\r
+                  <phase>package</phase>\r
+                  <goals>\r
+                     <goal>attach-artifact</goal>\r
+                  </goals>\r
+                  <configuration>\r
+                     <artifacts>\r
+                        <artifact>\r
+                           <file>${project.build.directory}/classes/${features.file}</file>\r
+                           <type>xml</type>\r
+                           <classifier>features</classifier>\r
+                        </artifact>\r
+                     </artifacts>\r
+                  </configuration>\r
+               </execution>\r
+            </executions>\r
+         </plugin>\r
+         <plugin>\r
+            <groupId>org.apache.maven.plugins</groupId>\r
+            <artifactId>maven-surefire-plugin</artifactId>\r
+            <version>${surefire.version}</version>\r
+            <configuration>\r
+              <systemPropertyVariables>\r
+                <karaf.distro.groupId>org.opendaylight.controller</karaf.distro.groupId>\r
+                <karaf.distro.artifactId>opendaylight-karaf-empty</karaf.distro.artifactId>\r
+                <karaf.distro.version>${commons.opendaylight.version}</karaf.distro.version>\r
+              </systemPropertyVariables>\r
+              <dependenciesToScan>\r
+               <dependency>org.opendaylight.yangtools:features-test</dependency>\r
+              </dependenciesToScan>\r
+            </configuration>\r
+          </plugin>\r
+      </plugins>\r
+   </build>\r
+   <scm>\r
+      <connection>scm:git:ssh://git.opendaylight.org:29418/controller.git</connection>\r
+      <developerConnection>scm:git:ssh://git.opendaylight.org:29418/controller.git</developerConnection>\r
+      <tag>HEAD</tag>\r
+      <url>https://git.opendaylight.org/gerrit/gitweb?p=controller.git;a=summary</url>\r
+   </scm>\r
+</project>\r
diff --git a/features/adsal-compatibility/src/main/resources/features.xml b/features/adsal-compatibility/src/main/resources/features.xml
new file mode 100644 (file)
index 0000000..de939f2
--- /dev/null
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- vi: set et smarttab sw=4 tabstop=4: -->
+<!--
+ Necessary TODO: Put your copyright statement here
+
+ This program and the accompanying materials are made available under the
+ terms of the Eclipse Public License v1.0 which accompanies this distribution,
+ and is available at http://www.eclipse.org/legal/epl-v10.html
+-->
+<features name="odl-adsal-compatibility-${sal.version}" xmlns="http://karaf.apache.org/xmlns/features/v1.2.0"
+          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+          xsi:schemaLocation="http://karaf.apache.org/xmlns/features/v1.2.0 http://karaf.apache.org/xmlns/features/v1.2.0">
+    <repository>mvn:org.opendaylight.controller/features-mdsal/${mdsal.version}/xml/features</repository>
+    <repository>mvn:org.opendaylight.controller/features-adsal/${sal.version}/xml/features</repository>
+    <repository>mvn:org.opendaylight.controller/features-flow/${mdsal.version}/xml/features</repository>
+    <feature name='odl-adsal-compatibility-all' version='${project.version}' description='OpenDaylight :: controller :: All'>
+        <feature version='${sal.version}'>odl-adsal-compatibility</feature>
+    </feature>
+    <feature name='odl-adsal-compatibility' description="OpenDaylight :: AD-SAL :: Compatibility" version="${sal.version}">
+      <feature version="${mdsal.version}">odl-mdsal-broker</feature>
+      <feature version="${mdsal.version}">odl-flow-model</feature>
+      <feature version="${sal.version}">odl-adsal-all</feature>
+      <bundle>mvn:org.opendaylight.controller/sal-compatibility/${mdsal.version}</bundle>
+   </feature>
+</features>
index 88ed749..039060b 100644 (file)
@@ -25,5 +25,6 @@
     <module>flow</module>
     <module>netconf</module>
     <module>protocol-framework</module>
+    <module>adsal-compatibility</module>
   </modules>
-</project>
+</project>
\ No newline at end of file