Fix warnings in poms - duplicate and incorrect dependencies 32/1932/2
authorAlissa Bonas <abonas@redhat.com>
Wed, 16 Oct 2013 14:12:51 +0000 (17:12 +0300)
committerGerrit Code Review <gerrit@opendaylight.org>
Thu, 17 Oct 2013 08:48:43 +0000 (08:48 +0000)
Change-Id: Ia8978555a51ae9be02782b8c70d8867fe2052c7a
Signed-off-by: Alissa Bonas <abonas@redhat.com>
opendaylight/md-sal/pom.xml
opendaylight/md-sal/sal-binding-broker/pom.xml
opendaylight/md-sal/sal-compability/pom.xml
opendaylight/netconf/netconf-impl/pom.xml
opendaylight/northbound/commons/pom.xml
opendaylight/usermanager/api/pom.xml

index 478bba8..c5ffe43 100644 (file)
             <plugin>
                 <groupId>org.apache.maven.plugins</groupId>
                 <artifactId>maven-jar-plugin</artifactId>
+                <version>2.4</version>
             </plugin>
             <plugin>
                 <groupId>org.apache.maven.plugins</groupId>
index 5d3572f..0d86eca 100644 (file)
@@ -95,9 +95,5 @@
             <groupId>org.eclipse.xtend</groupId>
             <artifactId>org.eclipse.xtend.lib</artifactId>
         </dependency>
-        <dependency>
-          <groupId>junit</groupId>
-          <artifactId>junit</artifactId>
-        </dependency>
     </dependencies>
 </project>
index 431ecfa..a66b82e 100644 (file)
       <artifactId>sal-binding-api</artifactId>
       <version>1.0-SNAPSHOT</version>
     </dependency>
-    <dependency>
-      <groupId>org.opendaylight.controller</groupId>
-      <artifactId>sal-common-util</artifactId>
-      <version>1.0-SNAPSHOT</version>
-    </dependency>
     <dependency>
       <groupId>com.google.guava</groupId>
       <artifactId>guava</artifactId>
index b52e85b..068c1f7 100644 (file)
             <plugin>
                 <groupId>org.apache.maven.plugins</groupId>
                 <artifactId>maven-jar-plugin</artifactId>
+                <version>2.4</version>
             </plugin>
         </plugins>
     </build>
index 1a450bf..8e769a2 100644 (file)
       <artifactId>bundlescanner</artifactId>
       <version>0.4.1-SNAPSHOT</version>
     </dependency>
-    <dependency>
-      <groupId>com.sun.jersey</groupId>
-      <artifactId>jersey-core</artifactId>
-    </dependency>
     <dependency>
       <groupId>org.codehaus.jackson</groupId>
       <artifactId>jackson-core-asl</artifactId>
     <dependency>
       <groupId>com.sun.jersey</groupId>
       <artifactId>jersey-core</artifactId>
-      <version>${jersey.version}</version>
     </dependency>
     <dependency>
       <groupId>com.sun.jersey</groupId>
index 78825e1..14a3059 100644 (file)
       <groupId>junit</groupId>
       <artifactId>junit</artifactId>
     </dependency>
-    <dependency>
-      <groupId>org.springframework.security</groupId>
-      <artifactId>spring-security-core</artifactId>
-    </dependency>
     <dependency>
       <groupId>equinoxSDK381</groupId>
       <artifactId>javax.servlet</artifactId>