Fix odl-model-project pom to include correct version of yang-bindings 68/2668/1
authorGiovanni Meo <gmeo@cisco.com>
Tue, 12 Nov 2013 14:55:03 +0000 (15:55 +0100)
committerGiovanni Meo <gmeo@cisco.com>
Tue, 12 Nov 2013 14:55:03 +0000 (15:55 +0100)
- yang-bindings need to be at the revision of the yang.codegen.version
else the code generation will create objects that are not present in
the runtime bindings

Change-Id: I753195ea8fedce178924eee2bb6d2e916bfc66dc
Signed-off-by: Giovanni Meo <gmeo@cisco.com>
opendaylight/archetypes/odl-model-project/src/main/resources/archetype-resources/pom.xml

index 1f9bc74..77f419a 100644 (file)
     <dependency>\r
       <groupId>org.opendaylight.yangtools</groupId>\r
       <artifactId>yang-binding</artifactId>\r
     <dependency>\r
       <groupId>org.opendaylight.yangtools</groupId>\r
       <artifactId>yang-binding</artifactId>\r
-      <version>${yang.version}</version>\r
-    </dependency>\r
-    <dependency>\r
-      <groupId>org.opendaylight.yangtools</groupId>\r
-      <artifactId>yang-common</artifactId>\r
-      <version>${yang.version}</version>\r
+      <version>${yang.codegen.version}</version>\r
     </dependency>\r
   </dependencies>\r
 </project>\r
     </dependency>\r
   </dependencies>\r
 </project>\r