Add dependency on javax.validation validation-api 55/37555/3
authorRyan Goulding <ryandgoulding@gmail.com>
Wed, 13 Apr 2016 15:27:38 +0000 (11:27 -0400)
committerTom Pantelis <tpanteli@brocade.com>
Wed, 13 Apr 2016 18:25:25 +0000 (18:25 +0000)
commitc4866dd4ddd707966293e2c159977997e5880d17
tree799a73aa3bdd5e45e6cca2205cd9f02e7a9f078d
parentf6d24d05f430c6f052893cb3a12d697cbb928815
Add dependency on javax.validation validation-api

In order to upgrade to org.eclipse.persistence to 2.6.0+ in odlparent,
downstream consumers must include the dependency on javax.validation
validation-api version 1.1.0.Final as described here:

http://stackoverflow.com/questions/28568154/
how-to-get-eclipselink-2-6-0-m3-working-with-jersey-1-18-3

The work to upgrade odlparent's moxy version is included in this patch:
https://git.opendaylight.org/gerrit/#/c/37541/

Change-Id: Ia3dc42c498a334d36fefb49fe7ddb936638987b7
Signed-off-by: Ryan Goulding <ryandgoulding@gmail.com>
features/config-persister/pom.xml
features/config-persister/src/main/features/features.xml
opendaylight/config/config-persister-directory-xml-adapter/pom.xml
opendaylight/config/config-persister-file-xml-adapter/pom.xml
opendaylight/md-sal/sal-binding-it/pom.xml

©2013 OpenDaylight, A Linux Foundation Collaborative Project. All Rights Reserved.
OpenDaylight is a registered trademark of The OpenDaylight Project, Inc.
Linux Foundation and OpenDaylight are registered trademarks of the Linux Foundation.
Linux is a registered trademark of Linus Torvalds.