Removing config subsystem as it does not load in the controller. 58/1758/2
authorEd Warnicke <eaw@cisco.com>
Wed, 9 Oct 2013 00:06:29 +0000 (19:06 -0500)
committerGerrit Code Review <gerrit@opendaylight.org>
Wed, 9 Oct 2013 00:49:08 +0000 (00:49 +0000)
Some notes on this:
1)  Config appears to be missing some yangtools.binding-generator-*
    dependencies that are needed in
    opendaylight/distribution/opendaylight/pom.xml
2)  Attempts to add those dependency fail because they need to
    be higher versions ( 0.6.0-SNAPSHOT and 0.5.9-SNAPSHOT)
    than the current setting for
    <yangtools.version> for the controller.
3)  Attempts to move the controller to use those higher versions
    causes other failures on load.

Config subsystem will be restored to the distribution as soon as it
works with the yangtools version being used in the controller.

Change-Id: Ic5e5c074531bee84494a42517d9de83b93793711
Signed-off-by: Ed Warnicke <eaw@cisco.com>
opendaylight/distribution/opendaylight/pom.xml

index 0bb4088..e259296 100644 (file)
           <version>${concepts.version}</version>
         </dependency>
 
-        <!-- config -->
+        <!-- config
         <dependency>
           <groupId>org.opendaylight.controller</groupId>
           <artifactId>config-api</artifactId>
           <artifactId>logback-config</artifactId>
           <version>${config.version}</version>
         </dependency>
+        -->
       </dependencies>
     </profile>
   </profiles>